1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cam sensor fault code, please help

Discussion in 'Other Almera Discussion' started by john n, Feb 26, 2018.

  1. john n

    john n

    Messages:
    4
    Likes Received:
    0
    Model:
    almera dci 2.2 112 bhp
    Chassis:
    2006-n16
    need help please with cam sensor code po340 ,,anyone around to help???????????????
     
  2. edk

    edk Addicted to Torque Staff Member

    Messages:
    25,648
    Likes Received:
    6,335
    Location:
    Hampshire
    Model:
    SXE DCi
    Chassis:
    N16
    Could need a new cam sensor? I would try that first. If the fault remains then it might be a sretched timing chain. It's not as common as on the petrol engines, but it has been known to happen on Diesels too.
     
  3. john n

    john n

    Messages:
    4
    Likes Received:
    0
    Model:
    almera dci 2.2 112 bhp
    Chassis:
    2006-n16
    hows th
     
  4. john n

    john n

    Messages:
    4
    Likes Received:
    0
    Model:
    almera dci 2.2 112 bhp
    Chassis:
    2006-n16
    hows things..ill tel ya its a cam sensor code..now the old sensor waant pulling to ground in which it should,,i got a new sensor and stil no change as in swipe a spanner across the sensor the voltage should change but didint on both old and new sensors ,so its leading me to a bad ecu,,beacuse if it was the timing chain problem then the voltage shud have changed on the new sensor as i swiped a spanner across it so thats evedience enough that its ecu related and defo not the chain,plus on red and black wire i have 5 volts on each wire in which i think the black shudnt have any voltage only the red wire..its 3 pin red blck and white,,white is ground red is power and blck shud be signal as far as i know,,but the thing im not sure about thou is shuold i have 5 volts on both black and red while engine is running.