LCD display not working & Heater stuck on full power, Almera 2005 1.5 Litre Petrol

I have just bought a Nissan Almera 2005 1.5 Litre Petrol. After a few days the LCD display has gone blank and the heater is stuck on full.l have checked all the fuses and had a mechanic look at the display which worked for a couple of days after he removed the display and put it back on despite finding no problems.If i disconnect the car battery for a few minutes everything works fine for a few hours when I reconnect it but when left overnight it reverts to a blank screen with heater stuck on full. Can anyone out there suggest a solution as this has stumped two mechanics !!!!
 

edk

Addicted to Torque
Staff member
Hi Joe, welcome to the club. Someone had this issue recently and found that there were some damaged wires between the ECU and components and between them and the engine bay (I think a power wire there). Get the loom checked out and maybe replace some of the wires.

Someone else tried just replacing the units, but it did nothing so it's more likely the wires. Not an easy job getting to all those wires I'm afraid though!
 
Hi Joe, welcome to the club. Someone had this issue recently and found that there were some damaged wires between the ECU and components and between them and the engine bay (I think a power wire there). Get the loom checked out and maybe replace some of the wires.

Someone else tried just replacing the units, but it did nothing so it's more likely the wires. Not an easy job getting to all those wires I'm afraid though!
 
Top Bottom