1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Screen/radio/heater are dead!

Discussion in 'Everything ICE' started by jmurray01, Mar 2, 2017.

  1. jmurray01

    jmurray01

    Messages:
    5
    Likes Received:
    1
    Model:
    Almera SE 1.8
    Chassis:
    N16
    It is a 2003 Almera SE with the stupid (in my opinion) computer controlled radio and heater, with the screen in the centre of the dashboard. What was wrong with a separate stereo and manual heater controls? Who knows, but Nissan seemed to think a more complicated system was necessary.

    Anyway, the screen is completely dead as is the radio and all the central buttons (including rear screen demist), and the heater cannot be adjusted, but does come on when the engine gets up to operating temperature and keeps the car at around 20 celsius. Don't ask me how that works, but I'm glad that it just happens to be "stuck" at a tolerable temperature rather than on full blast hot or cold, which would be most inconvenient.

    Does anybody have any ideas what the problem could be, and any easy solutions? It was a very cheap car and I don't want to spend too much money or time on it, but at the same time I intend on keeping it until the MOT expires in October, so would like to have a working stereo and air conditioning to use for the next 7 months if possible!

    Thank you in advance.
     
  2. Riad

    Riad

    Messages:
    6
    Likes Received:
    0
    Model:
    SE
    Chassis:
    N16
    Hello
    Once my radio went dead, but the heating controls were still working.....and a few weeks after that it wouldn't start and door locks kept clicking!!
    It was solved by just charging the battery!.....have you checked the battery?...good luck
     
  3. jmurray01

    jmurray01

    Messages:
    5
    Likes Received:
    1
    Model:
    Almera SE 1.8
    Chassis:
    N16
    The battery is OK in so far as it starts the car with no problem, even after sitting for 3 weeks before I bought it. I will try disconnecting it for 15 minutes and reconnecting to simulate changing it in case that does anything.
     
  4. alex92NA

    alex92NA

    Messages:
    15
    Likes Received:
    0
    Model:
    Techna
    Chassis:
    N16
    Have you checked the two connectors that goes on the back of console ?

    Στάλθηκε από το Redmi 3 μου χρησιμοποιώντας Tapatalk
     
  5. jmurray01

    jmurray01

    Messages:
    5
    Likes Received:
    1
    Model:
    Almera SE 1.8
    Chassis:
    N16
    Would that stop the radio and heater from working though? I thought that would just disconnect the screen but leave the functions operable.

    I shall have a look though.
     
  6. alex92NA

    alex92NA

    Messages:
    15
    Likes Received:
    0
    Model:
    Techna
    Chassis:
    N16
    They one just turn off the radio and the other just keep the heater on all the time.... just saying that could be a problem there...

    Στάλθηκε από το Redmi 3 μου χρησιμοποιώντας Tapatalk
     
  7. amitabh

    amitabh

    Messages:
    1
    Likes Received:
    0
    Model:
    SVE
    Chassis:
    N16
    I have same problem.. the centre console stopped working along with heater, dvd system (sat nav) radio, and dashboar heating. Only thing that can be done is takikngcd out of drive and rear heating. Any help??