Stani's SR20 Micra Build

Good thing it's a chain engine ain't it? you're going to get some lightweight wheels and black diamond brakes or so?

Yes but worst case the engine is removed to do any work as its not a big job. Wheels and brakes I haven't really looked at yet, still a fair bit of engine/ecu work to do before I move onto the last few bits. I'd like a set of prorace 1.2's and wilwoods maybe at a later date
 
Yes but worst case the engine is removed to do any work as its not a big job. Wheels and brakes I haven't really looked at yet, still a fair bit of engine/ecu work to do before I move onto the last few bits. I'd like a set of prorace 1.2's and wilwoods maybe at a later date

I almost had forgot that you have to remove the engine even on the N15 to do it, it is also one of worst chain engines when thought of the change interval, you got it working yet? or what's left?

You're going to get N15 brakes or change the bolt pattern to 4x114 (for 200SX/N16 brakes) or not yet even thought of?
 
4 and bit years later the car is now roadworthy, i have a few running issues currently but it drives and shifts well for only being 1-2psi of boost with very light throttle. Once the issues have been fixed including ecu problems i will book in for mapping and hopefully return with a decent figure

Cheers
 
4 and bit years later the car is now roadworthy, i have a few running issues currently but it drives and shifts well for only being 1-2psi of boost with very light throttle. Once the issues have been fixed including ecu problems i will book in for mapping and hopefully return with a decent figure

Cheers
Admirable persistence and congrats on getting the build roadworthy!
 
Thank you nugget, its been a long road but it has paid off.

Still have slight overheating issues, originally i blanked off the heater matrix pipes but turns out this caused it to overheat whilst motorway driving. Last night i added in a pipe and removed the thermostat and Re-filled the coolant which showed much improvement but after a few hours and then driving around town the temperature started to go high and was temperamental!

Back up today to hopefully get any last air from inside and hope thats the issue, otherwise ill need to start looking at any blockages/water pump and headgasket. Im suggesting headgasket purely because on the MOT retest at the fast idle test the temperature went up pretty fast and reached the red, on the first MOT i wasnt there to see and it wasnt long after driving away i started to have the problems...
 
Last edited:
Topped up the system and it never really took much more, took out for another drive and once again on the country roads going at speeds from 50-60 the car is a dream and temperature stays perfect. 10-15 mins town driving and its a overheating mess and motorway driving does not bring it back down.

Currently i have OAT readymixed coolant, i have removed the thermostat (which i am most likely going to refit) i have a slightly larger capacity radiator than standard, core size- 388x310x50 v the stock 320x657x21. And my radiator cap is 1.1bar which i may change to a 0.9bar

Any other suggestions
 
If i hooked up the laptop i could, and the rad was cleaned out with a hose and is also brand new

Anyway some good news. I have tonight refitted the thermostat and spent half an hour making sure all the air is out aswell as changing the fan to pull rather than push and it worked a treat! Few hours of mixed driving and the temperature stayed midway. Few other issues to get over now
 
Top Bottom