How To: Airbag Reset

Discussion in 'Other Almera Discussion' started by edk, Jan 6, 2012.

  1. edk

    edk Addicted to Torque Staff Member

    Messages:
    25,649
    Likes Received:
    6,338
    Location:
    Hampshire
    Model:
    SXE DCi
    Chassis:
    N16
    Hows this done please? :) Mine's been flashing since I removed my seat at shakeys and even though it's all connected back up it still flashes.
     
  2. Hally

    Hally Administrator Staff Member

    Messages:
    11,301
    Likes Received:
    4,497
    Location:
    Leeds
    Model:
    ZX Turbo
    Chassis:
    T72
    Is there a fault code? try the below, cant harm anything.

    HOW TO CHANGE SELF-DIAGNOSIS MODE WITHOUT CONSULT-II
    From User Mode to Diagnosis Mode
    When a malfunction is detected, activate the Diagnosis mode by turning the ignition switch as follows:
    1) Turn ignition switch “ON”.
    2) After “AIR BAG” warning lamp lights for 7 seconds, turn ignition switch “OFF” within 1 second.
    3) Wait more than 3 seconds.
    4) Repeat steps 1 to 3 three times.
    5) Turn ignition switch “ON”.
    SRS will not enter Diagnosis mode if no malfunction is detected.

    From Diagnosis Mode to User Mode
    After a malfunction is repaired, switch the ignition “OFF” for at least one second, then back “ON”. Diagnosis
    mode is returned to User mode.
    When a malfunction is detected, switch from Diagnosis mode to User mode by turning the ignition switch as
    follows:
    1) Turn ignition switch “ON”.
    2) After “AIR BAG” warning lamp lights for 7 seconds, turn ignition switch “OFF” within 1 second.
    3) Wait more than 3 seconds.
    4) Repeat steps 1 to 3 three times.
    5) Turn ignition switch “ON”.
     
    Darchitect, V-SpecII and edk like this.
  3. edk

    edk Addicted to Torque Staff Member

    Messages:
    25,649
    Likes Received:
    6,338
    Location:
    Hampshire
    Model:
    SXE DCi
    Chassis:
    N16
    Cheers, didn't think there was a way without Consult, so cheers :). Is that actually a reset or..? No MIL fault code that I can read with my OBD thinga.
     
  4. Hally

    Hally Administrator Staff Member

    Messages:
    11,301
    Likes Received:
    4,497
    Location:
    Leeds
    Model:
    ZX Turbo
    Chassis:
    T72
    if you read the FSM, its not too clear on an actual "reset" procedure, but I inferred that you put it into diag mode, see what the flashes are, fix it (which you have already done), then put it in user mode.

    OR, it may be in diagnosis mode anyway as there was a fault, and you just need to return it user mode.

    Worth a bash anyway.
     
    edk likes this.
  5. edk

    edk Addicted to Torque Staff Member

    Messages:
    25,649
    Likes Received:
    6,338
    Location:
    Hampshire
    Model:
    SXE DCi
    Chassis:
    N16
    Found on Navara forum, which adds I guess the reset part:


     
    rowdy-GTi, damienga15de and V-SpecII like this.
  6. Hally

    Hally Administrator Staff Member

    Messages:
    11,301
    Likes Received:
    4,497
    Location:
    Leeds
    Model:
    ZX Turbo
    Chassis:
    T72
    that's what I said.
     
  7. edk

    edk Addicted to Torque Staff Member

    Messages:
    25,649
    Likes Received:
    6,338
    Location:
    Hampshire
    Model:
    SXE DCi
    Chassis:
    N16
    Yes. I'm saying the Navara guys confirm that's what resets it :).
     
  8. Liam

    Liam

    Messages:
    13,045
    Likes Received:
    4,629
    Location:
    North Devon
    Model:
    Burner
    Chassis:
    Oil
    I shall try that on mine, once its running of course :)
     
  9. edk

    edk Addicted to Torque Staff Member

    Messages:
    25,649
    Likes Received:
    6,338
    Location:
    Hampshire
    Model:
    SXE DCi
    Chassis:
    N16
    Just tried this and worked a treat. It's good to go by the advice in the second instructions (quoted) as well as the 7 second rule to make sure you're doing it right.
     
  10. stufagti

    stufagti

    Messages:
    6,489
    Likes Received:
    90
    Location:
    romford essex
    Model:
    gti
    Chassis:
    1998
    good work edvardo! MOT here we come :):)

    i wonder if you removed the seats (ie airbags) for some comfy bucket ones, will this still work?
     
  11. Hally

    Hally Administrator Staff Member

    Messages:
    11,301
    Likes Received:
    4,497
    Location:
    Leeds
    Model:
    ZX Turbo
    Chassis:
    T72
    No.
     
  12. edk

    edk Addicted to Torque Staff Member

    Messages:
    25,649
    Likes Received:
    6,338
    Location:
    Hampshire
    Model:
    SXE DCi
    Chassis:
    N16
    +1 Definitely not.
     
  13. V-SpecII

    V-SpecII

    Messages:
    1,494
    Likes Received:
    210
    Location:
    Mani
    Model:
    2.2 DCi SXE
    Chassis:
    2005
    I haven't started my05 mera in 2 weeks, battery was disconnected too, damn light randomly started flashing. This reset procedure Worked like a treat cheers fellas!!
     
  14. damienga15de

    damienga15de

    Messages:
    4,603
    Likes Received:
    1,613
    Location:
    westmeath ireland
    Model:
    VZR N-1
    Chassis:
    n15

    Lifesaver again edk, just reset mine again seems to need it once a year

    Sent from my GT-I9300 using Tapatalk 2
     
  15. edk

    edk Addicted to Torque Staff Member

    Messages:
    25,649
    Likes Received:
    6,338
    Location:
    Hampshire
    Model:
    SXE DCi
    Chassis:
    N16
    Used this myself just a couple of days ago.

    -phone-
     
  16. lindasmur13

    lindasmur13

    Messages:
    8
    Likes Received:
    1
    Location:
    SOUTHAMPTON
    Model:
    1.5 SE
    Chassis:
    2000 - present
    did this on mine October last year, and saved nearly £100 for 1hr diagnostic test at the main dealers
     
  17. V-SpecII

    V-SpecII

    Messages:
    1,494
    Likes Received:
    210
    Location:
    Mani
    Model:
    2.2 DCi SXE
    Chassis:
    2005
    I was trying the reset, but I followed the above in error, instead of the 1 Ed posted, now it keeps making a tick sound & lights flash on on dash randomly & doesn't start!! HELP someone!!!
     
  18. V-SpecII

    V-SpecII

    Messages:
    1,494
    Likes Received:
    210
    Location:
    Mani
    Model:
    2.2 DCi SXE
    Chassis:
    2005
    Has anyone got any idea how to fix this or any ideas what I need to do to get it the car working again.?? Need my car to commute back & fourth to work, sorry to post again but I'm so depressed. :(
     
  19. Hally

    Hally Administrator Staff Member

    Messages:
    11,301
    Likes Received:
    4,497
    Location:
    Leeds
    Model:
    ZX Turbo
    Chassis:
    T72
    the one Ed posted is the one you quoted, but in plain english instead of Nissan speak.

    you have definitely done the last part of that procedure?

    -phone-
     
  20. V-SpecII

    V-SpecII

    Messages:
    1,494
    Likes Received:
    210
    Location:
    Mani
    Model:
    2.2 DCi SXE
    Chassis:
    2005
    Thanks for the reply Hally, yes I did the first part of the procedure, but didn't carry on to do the second part (diagnosis to user mode), but then followed through the 1 that Ed posted.

    Now when I turn the key in the ignition random ticks can be heard, dash lights are flashing to the ticks which occur every few milliseconds, the central locking isn't activating, it makes a weak sound as though the doors are locked but it doesn't actually lock.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice